wow classic era updated to version 1.14.0
  • Author: Furious
  • Date: September 29, 2021
  • Expansion: WoW Classic

Blizzard has upgraded infrastructure to WoW Classic Era realms with patch 1.14.0 being released. This is not a content patch as you can see in the quote below, this is an update to infrastructure and server-side changes.

Patch Notes

This version updates the WoW Classic client to accompany recent server-side and infrastructure updates that have been made to the World of Warcraft service.

Kaivax – (Source)

We’ve completed maintenance on Classic Era to upgrade to version 1.14.0, and all realms are again live.

At this time on Americas and Oceanic Classic Era realms, we have closed the in-game shop while we fix a shop-related bug. We expect to open the in-game shop back up soon.

This patch is intended to update our infrastructure, and does not include content changes. Part of the infrastructure updates requires us to update our Addon API, which can break existing addons, as any patch can.

However, while we can’t guarantee the behavior of any specific addon, it’s possible that addons currently supported in Burning Crusade Classic will now work for Classic Era. Addon authors should be able to make that determination for their specific addons.

Regarding camera and targeting issues, we suggest that you check your interface options for Camera Following Style (Esc/Interface Options/Camera) and Sticky Targeting (Esc/Interface Options/Controls). These may have changed from the setting you were expecting.

If you continue to experience issues, please report them in our Bug Report forum.

Thank you!

About the Author

Furious

If I'm not working or spending time with the family I'm probably gaming. Some of my favorite recent games I've played are Far Cry 5, World of Warcraft Classic, and 7 Days to Die.

Subscribe
Notify of
guest
4 Comments
Most Voted
Newest Oldest
Inline Feedbacks
View all comments
Johan Van Laken
Johan Van Laken
25 days ago

I ran Wow Classic on a very old system, there must have been changes in the graph requirements because my system cannot run it anymore, much like TBC classic. This is quite strange because on that same old laptop, I played retail WoW up until Legion. I understand games evolve, but this is my death setence in wow because I cannot even run the most basic version of the game anymore and was not even informed of this…

BruceMangee
BruceMangee
Reply to  Johan Van Laken
22 days ago

They use the shadowland API now, every AddOn with certain legacy API calls will be broken

JOSka
JOSka
Reply to  Johan Van Laken
1 day ago

You can try to launch WoW with DirectX 11 instead of DirectX 12. From Blizzard:

  • DirectX version can also be changed out of game through the command line arguments in the Battle.net desktop app. With the Battle.net desktop app opened and WoW selected click on Options
  • Select Game Settings
  • Find WoW and check the box for Additional command line arguments
  • In the new box enter the command for the desired DirectX version:
  1. -d3d11legacy
  2. -d3d11
  3. -d3d12
  • Click Done to save.

So you may try to use one of the “-d3d11legacy” or “-d3d11” arguments.

(I am playing on Windows 7 Ultimate, with a Core 2 Quad Q8300 from 2008 and a graphic card that is not supported anymore by AMD.)

Last edited 1 day ago by JOSka
geohnwill71@gmail.com
15 days ago

It is total utter garbage. A pure lie and slap in the face to say we will have museum servers in ERA, then F- them up.. But hey, that is the S- of Blizz

Scroll to Top